Admin portal unavailable

Incident Report for Uniqkey

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 11:17 CET

Identified

The Uniqkey admin portal is currently unavailable, possibly due to maintenance from our hosting provider. To access your admin portal, please use our backup URL instead: https://app.next.uniqkey.eu/

We apologise for the inconvenience.
Posted Jan 27, 2026 - 10:47 CET
This incident affected: Frontend (Organization Portal).