Blank extension after updating to Chrome + Edge version 144

Incident Report for Uniqkey

Resolved

This issue only affects people using a beta version of Chrome and Edge.

A fix will be implemented on our end to ensure full support for those browsers when their latest versions are deployed to the public.

In the meantime, using a standard release of mentioned browsers will work as expected.
Posted Dec 16, 2025 - 09:24 CET

Identified

Our development team has been notified of users seeing a blank extension window after updating their Chrome and Edge browsers to version 144.

We're currently working on a solution.

Using another browser like Firefox works as expected.

If Firefox is not installed on your PC, you can download it here: https://www.mozilla.org/en-GB/firefox/windows/
The Uniqkey extension for Firefox can be downloaded here: https://addons.mozilla.org/en-GB/firefox/addon/uniqkey/

You can also still view your saved data in your Uniqkey mobile app.

We sincerely apologise for the inconvenience.
Posted Dec 16, 2025 - 09:10 CET
This incident affected: Frontend (Browser Extension App).