Can't connect to server

Incident Report for Uniqkey

Resolved

Our systems have recovered, and the extension should be live again shortly.

If you still experience any technical difficulties, please contact our Support team via email support@uniqkey.eu.
Posted Dec 19, 2025 - 13:37 CET

Identified

Our development team has been notified of a "trouble connecting to server" error.

We're currently recovering our systems, and expect the browser extension to be live again soon.

We apologise for the inconvenience.
Posted Dec 19, 2025 - 13:32 CET
This incident affected: Frontend (Browser Extension App).